N900 virtual keyboard not working after uninstall SCIM


maemoMy N900 virtual keyboard not working after i installed SCIM for Maemo, i tot it’ll be fine after i uninstall it. However, my virtual keyboard still not working after uninstall the scim for maemo. I’ve been searching for a solution for few days but no luck. Just i’m going to give up and decided to re-flash my N900, i found a solution posted at the scim for maemo issue forum. If you dare to try, then you may proceed, else you may exit.

To solve the virtual keyboard not working after uninstall scim, follow the steps below:-

Advertisements

  • To perform this solution you need to install ‘gainroot’
  • Start your X-Terminal and enter
  • Next, go to /etc/event.d and check if there is a file named ‘scim’

    if this scim is available, you can remove it using the command below:-

  • Next you need to enter this command:-

  • Done, reboot your N900 and your virtual keyboard should be working by now.

Disclaimer: I held no responsibilities for any damage done to your machine. DO THIS AT YOUR OWN RISK!


Credit: scim-for-maemo

Related posts:






Share this with your friends:-

7 Responses to “N900 virtual keyboard not working after uninstall SCIM”

  1. Ruth says:

    Well, I tried to do the code at first but I got one part of the code wrong and had to re-do it again. But when I was doing it, the scim was nowhere to be found but the virtual keyboard wasn’t working still after reboot. What I did was install MSCIM again and uninstall it. Luckily, when I uninstalled it, the keyboard worked already so I didn’t have to do this code anymore. 🙂 But still, thanks.

  2. Danny says:

    I am so thankful.it worked perfectly well.For the people who dont know what “>” means,it just means press ENTER.Thanks mate.

  3. Sacha says:

    This solution worked for me perfectly. I am using PR 1.3 for my n900 and it actually brought back the vkb for PR 1.2. Thnx bro.. keep up the good work. thnx for sharing..

  4. Jan says:

    Thanks a lot! Fix worked well on my N900 also after I had experimented with the “mscim-n900-ppinputmethod”-app.

  5. ashfaq says:

    i want to try this command but can any one let me know how to put a ” > ” from the N900 hardware keyboard.

  6. case8888 says:

    hi.. Ive tried all the steps above

    At the last step of:-
    /usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

    There were no response.. and after phone restart
    Still the same thing.. Please guide!

  7. Srinivasan says:

    Hi,

    It worked for me. Thanks a lot for sharing.

    With Regards,

    Srini.

Leave a Reply